Benötigte Pakete für VLC installieren

sudo apt-get build-dep vlc

Aktuelles yasm installieren:

sudo apt-get build-dep yasm
sudo apt-get remove yasm
cd /usr/local/dev/
wget http://www.tortall.net/projects/yasm/releases/yasm-0.7.1.tar.gz
tar xfvz yasm-0.7.1.tar.gz
cd yasm-0.7.1/

./configure --prefix=/usr --enable-shared --enable-pthread

make
sudo make install

VLC installieren:

sudo apt-get remove x264
sudo apt-get install libgpac-dev git-core libqt4-dev libxpm-dev
cd /usr/local/dev/
wget http://nightlies.videolan.org/build/source/latest/vlc-snapshot-$(date +%Y%m%d).tar.bz2
tar xfvj vlc-snapshot-$(date +%Y%m%d).tar.bz2
cd vlc-0.9.0-test3/extras/
git clone git://git.videolan.org/x264.git
cd x264

./configure --enable-pthread --enable-debug --enable-pic --enable-shared --enable-gtk --enable-visualize --enable-mp4-output

make
sudo make install
cd ../

wget http://switch.dl.sourceforge.net/sourceforge/faac/faad2-2.6.1.tar.gz
tar xfvz faad2-2.6.1.tar.gz
cd faad2
./bootstrap

./configure --enable-shared --with-pic --with-drm --with-mpeg4ip

cd libfaad/
make
cd ../../../

./configure --prefix=/opt/vlc-0.9.0-test3 --enable-libtool --disable-gnome --disable-gtk --disable-familiar \
--disable-fb --enable-ggi --enable-sdl --enable-esd --enable-pulse --disable-qt --enable-mad --enable-arts \
--enable-alsa --enable-lirc --enable-a52 --enable-aa --enable-dvbpsi --enable-mozilla --enable-mp4 --enable-dvb \
--enable-dv --disable-satellite --enable-ogg --enable-vorbis --enable-wxwidgets --with-wx-config=wx-config \
--disable-slp --enable-flac --disable-skins --disable-basic-skins --enable-skins2 --enable-freetype --enable-mkv \
--enable-v4l --enable-pvr --enable-speex --enable-caca --enable-libmpeg2 --enable-fribidi --enable-cdio --enable-mod \
--enable-theora --enable-modplug --enable-dvdnav --enable-gnutls --enable-ffmpeg --enable-ncurses --enable-smb \
--disable-gnomevfs --enable-bonjour --enable-mpc --enable-vcd --enable-vcdx --enable-xosd --enable-notify --enable-jack \
--enable-dvd --disable-live555 --enable-x264 --with-x264-tree=extras/x264 --enable-faad --with-faad-tree=extras/faad2

make
sudo make install

Vlc über ein Script starten

cd /usr/local/bin/
sudo vi vlc9


#!/bin/bash

VLCPATH=/opt/vlc-0.9.0-test3/

##############

export PATH=$PATH:$VLCPATH/bin
export LD_LIBRARY_PATH=$VLCPATH/lib:$LD_LIBRARY_PATH

$VLCPATH/bin/vlc

sudo chmod 755 /usr/local/bin/vlc9

Tags: ,

Name
E-Mail (wird nicht veröffentlicht)
Website
Bitte beachten sie, dass ihr Kommentar möglicherweise erst freigeschaltet werden muss.